FAQ: Instalação

Como eu posso começar?

  1. Baixando o código.
  2. Instalando o Django (leia a guia de instalação).
  3. Navegue pelo tutorial.
  4. Confira o resto da documentação e faça perguntas se você tiver problemas.

Quais são os pré-requisitos do Django?

O Django requer Python. Veja a tabela na próxima questão para visualizar as versões de Python que funcionam com cada versão do Django. Outras bibliotecas Python podem ser requeridas para alguns casos de uso, mas você receberá um erro sobre elas na medida que forem necessárias.

Para um ambiente de desenvolvimento – se você só quer experimentar com Django – você não precisa ter um servidor web separado instalado ou um servidor de banco de dados.

Django vem com seu próprio servidor de desenvolvimento. Para um ambiente de produção, o Django segue as especificações WSGI, PEP 3333, o que significa que é possível executar em uma variedade de servidores web. Veja a documentação Implementando o Django para mais informações.

Django executa SQLite por padrão, pois é incluso na instalação do Python. Para um ambiente de produção, recomendamos usar o PostgreSQL; mas também suportamos oficialmente MariaDB, MySQL, SQLite e Oracle. Veja :doc:Bancos de Dados Suportados</ref/databases>` para mais informações.

Qual versão do Python eu posso usar com Django?

Versão do Django Versões do Python
1.11 2.7, 3.4, 3.5, 3.6 e 3.7 (adicionado na versão 1.11.17)
2.0 3.4, 3.5, 3.6, 3.7
2.1 3.5, 3.6, 3.7
2.2 3.5, 3.6, 3.7, 3.8 (adicionado na 2.2.8)
3.0 3.6, 3.7, 3.8

Para cada versão do Python, apenas a micro versão (A.B.C) é oficialmente suportada. Você pode encontrar a micro versão mais recente para cada série na Página de downloads do Python.

Typically, we will support a Python version up to and including the first Django LTS release whose security support ends after security support for that version of Python ends. For example, Python 3.3 security support ended September 2017 and Django 1.8 LTS security support ended April 2018. Therefore Django 1.8 is the last version to support Python 3.3.

Qual versão do Python eu devo usar com Django?

Python 3 é recomendado. Django 1.11 é a última versão a suportar Python 2.7. Suporte para Python 2.7 e Django 1.11 termina em 2020.

Uma vez que as versões mais recentes do Python são muitas vezes mais rápidas, têm mais recursos e são melhor suportadas, a última versão do Python 3 é recomendada.

Você não perde nada no Django por usar uma distribuição antiga, mas você não usufruirá das melhorias e otimizações das versões mais recentes de Python. As aplicações de terceiros para uso com Django são, claramente, livres para definir os seus próprios requisitos de versão.

Eu devo usar a versão estável ou a versão de desenvolvimento?

Geralmente, se você estiver usando um código em produção, você deveria usar uma distribuição estável. O projeto do Django publica uma distribuição completa estável há aproximadamente cada nove meses com atualizações para correções de bugs. Essas distribuições estáveis têm uma API que é garantidamente compatível com a versão anterior; se você escrever código em distribuições estáveis você não deverá ter problemas para atualizar quando a próxima versão oficial for distribuída.

Back to Top