빠른 설치 가이드

Before you can use Django, you'll need to get it installed. We have a complete installation guide that covers all the possibilities; this guide will guide you to a minimal installation that'll work while you walk through the introduction.

파이썬 설치하기

파이썬 웹 프레임워크이므로, Django는 파이썬이 필요합니다. 자세한 내용은 장고와 어떤 파이썬 버전을 사용해야 하나요? 를 참조하세요. 파이썬은 SQLite 라 불리는 경량 데이터베이스를 가지고 있어서 여러분은 아직 데이터베이스를 설정할 필요가 없습니다.

최신 Python 버전은 https://www.python.org/downloads/ 또는 운영 체제 패키지 관리자에게 문의하십시오.

파이썬이 설치되었는지 확인하려면 Shell에서 python 이라고 입력하세요. 그러면 다음과 같은 문구가 나타날 겁니다:

Python 3.x.y
[GCC 4.x] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>>

데이터베이스 설정하기

This step is only necessary if you'd like to work with a "large" database engine like PostgreSQL, MariaDB, MySQL, or Oracle. To install such a database, consult the database installation information.

장고 설치하기

You've got three options to install Django:

  • 대부분의 유저들에게는 공식 릴리즈를 추천합니다.
  • 운영체제 에서 제공하는 Django 를 설치하세요.
  • 최신 개발 버전 설치하기. 이 옵션은 가장 최신 버전의 기능을 사용하기 원하는 열정적이고 도전적인 사람들을 위한 옵션입니다. 개발 버전을 사용할 경우 예기치 못한 새로운 버그에 맞닥뜨릴수도 있습니다. 이런 버그들을 발견하실 경우 버그 리포팅을 통해 Django개발에 도움을 주실 수 있습니다. 또한, 3rd-party-패키지의 경우에는 현재 Stable로 제공되는 릴리즈 버전보다는 호환성이 떨어질 수 있습니다.

항상 현재 사용하는 버전의 공식 문서를 참고하세요!

여러분이 처음 두 단계중 하나를 실행한다면, 문서에서 new in development version 라고 표시된 부분을 주의해서 보세요. 그 구문 플래그는 Django 개발 버전에서만 사용가능하고, 공식 릴리즈에서는 작동하지 않을것을 알려주는 기능을 합니다.

검토하기

Python이 Djagno를 찾을 수 있는지 확인하기 위해, 쉘에서 python이라고 입력하고 Python 프롬프트에서 Django를 임포트해보세요.

>>> import django
>>> print(django.get_version())
3.0

여러분은 다른 버전의 장고가 설치되어있을 수도 있습니다.

끝입니다!

이게 끝입니다. 이제, 튜토리얼 을 시작해보세요.

Back to Top