자주묻는 질문: 설치

어떻게 시작하나요?

  1. 코드를 다운로드하세요.
  2. 장고를 설치하세요 ( 설치 가이드를 읽으세요.)
  3. 튜토리얼을 따라 하세요.
  4. 장고 문서를 확인하시고, 문제가 있다면 질문하세요.

장고를 위해 준비해야 할것이 있나요?

장고는 파이썬을 필요로 합니다. 다음 질문에 장고의 각 버전별로 표시된 파이썬 버전들을 보세요. 다른 파이썬 라이브러리들은 쓸모가 있을지 모르지만 그것들이 필요할 때 에러가 생길 수 있습니다.

장고를 단순히 경험하고 싶다면 개발환경을 위해 개별 웹서버가 필요하지 않습니다. 장고는 그 자체의 가벼운 개발 서버를 가지고 있습니다. 제품 환경에 있어서는 장고는 WSGI spec PEP 3333을 따르기 때문에 다양한 서버 플랫폼에서 작동합니다. 장고 배포하기에서 많이 찾는 대안들을 살펴보세요.

장고와 데이터베이스를 함께 사용하고 싶으시다면, 데이터베이스 엔진이 필요하실 겁니다. 저희는 PostgreSQL을 추천합니다. MySQL_이나, SQLite 그리고 Oracle 또한 지원은 합니다.

장고와 어떤 파이썬 버전을 사용해야 하나요?

장고 버전 파이썬 버전들
1.11 2.7, 3.4, 3.5, 3.6, 3.7(1.11.17에 추가됨)
2.0 3.4, 3.5, 3.6, 3.7
2.1, 2.2 3.5, 3.6, 3.7

각 Python 버전에 대해, 최종 마이크로 릴리스(A.B.C)만을 공식적으로 지원합니다. Python 다운로드 페이지에서 최근 마이크로 버전 시리즈들을 찾을 수 있습니다.

일반적으로, 장고 LTS버전과 파이썬 버전들을 지원하는데 해당 버전의 파이썬 보안 지원이 끝나기 전까지 지원합니다. 예를들면 파이썬 3.3 보안 지원은 2017년 9월에 종료되고 Django1.8 LTS는 2018년 4월에 종료됩니다. 따라서 Django 1.8은 Python3.3 을 지원하는 마지막 버전입니다.

장고를 사용하기 위해 어떤 파이썬 버전을 사용해야 하나요?

파이썬 3를 추천합니다. 장고 1.11은 파이썬 2.7을 지원하는 마지막 버전입니다. 파이썬 2.7과 Django1.11에 대한 지원은 2020년에 끝납니다.

대게 새로운 파이썬 버전이 빠르고, 기능도 많고, 더 많은 지원을 하기 떄문에 가장 최근 파이썬 3 버전을 추천합니다.

예전 릴리즈의 장고를 사용한다고 잃는것은 아무것도 없습니다. 하지만 새로운 파이썬의 발전과 최적화 혜택을 받을 수 없습니다. 써드파티 애플리케이션 또한 그들의 버전 요구를 정할 수 있습니다.

개발중인 버전을 사용해야 하나요. 안정화된 버전을 사용해야 하나요?

일반적으로, 만약 제품을 위한 코드를 쓴다면 안정된 릴리즈 버전을 사용해야 합니다. 장고 프로젝트는 매 9달 정도 마다 중간에 버그 픽스가 추가된 안정된 릴리즈를 발표합니다. 이 안정된 릴리즈들은 이전 버전의 호환성을 보장하는 API들을 포함합니다. 안정된 릴리즈 버전으로 코드를 작성한다면 차후에 새로운 공식 릴리즈로 업그레이드 하는것에 문제가 없을 것입니다.

Back to Top