FAQ: Pemasangan

Bagaimana Saya memulai?

  1. Unduh kode.

  2. Pasang Django (baca panduan pemasangan).

  3. Berjalan melalui tutorial.

  4. Periksa sisanya dari documentasi, dan tanyakan pertanyaan jika anda berjalan kedalam masalah.

Apa itu prasyarat Django?

Django membutuhkan Python. Lihat tabel di pertanyaan selanjutnya untuk versi dari Python yang bekerja dengan setiap versi dari Django. Pustaka Python lainnya mungkin dibutuhkan untuk beberapa pengguna, tetapi anda akan menerima sebuah kesalahan tentangnya sesuai kebutuhan mereka.

Untuk lingkungan pengembangan – jika anda hanya ingin mencoba dengan Django – anda tidak ingin mempunyai peladen Jaringan terpisah dipasang; Django datang dengan peladen pengembangan ringan sendiri. Untuk lingkungan produksi, Django mengikuti spesifikasi WSGI, PEP 3333, yang berarti dia dapat berjalan pada beragam paladen. Lihat Menyebarkan Django untuk beberapa cara lain terkenal.

Jika anda ingin menggunakan Django dengan basisdata, yang kemungkinan terjadi, anda akan juga butuh mesin basisdata. PostgreSQL dianjurkan, karena kami penggemar PostgreSQL, dan MySQL, SQLite 3, dan Oracle juga didukung.

Versi Phyton apa dapat Saya gunakan dengan Django?

Versi Django

Versi Python

1.8

2.7, 3.2 (sampai akhir 2016), 3.3, 3.4, 3.5

1.9, 1.10 2.7, 3.4, 3.5

Untuk setiap versi dari Phyton, hanya terbitak mikro terakhir (A.B.C) adalah resmi yang didukung. Anda dapat menemukan versi mikro terakhir untuk setiap seri pada Halaman unduh Python.

Secara khusus, kami akan mendukung versi Phyton sampai dan termasuk terbitan LTS Django pertama yang dukungan keamanan berakhir setelah dukungan keamanan untuk versi tersebut dari Phyton berakhir. Sebagai contoh, dukungan keamanan Python 3.3 berakhir September 2017 dan dukungan keamanan Django 1.8 LTS berakhir April 2018. Karena itu Django 1.8 adalah versi terakhir untuk mendukung Phyton 3.3.

Versi Phyton apa harus Saya gunakan dengan Django?

Sebagai Django 1.6, dukungan Python 3 dipertimbangkan stabil dan anda dapat aman menggunakannya dalam produksi. Lihat juga Menyambungkan ke Phyton 3. Bagaimanapun, komunitas masih dalam proses dari memindahkan paket pihak-ketiga dan aplikasi ke Python 3.

Jika anda sedang memulai proyek baru, dan ketergantungan anda berencana menggunakan bekerja pada Python 3, anda harus menggunakan Python 3. Jika mereka tidak, pertimbangkan membantu usaha penghubungan, atau melekatkan ke Python 2.

Sejak versi terbaru dari Python sering tercepat, mempunyai fitur lebih, dan dukungan terbaik, semua menjadi sama, kami menganjurkan bahwa anda menggunakan terbitan 2.x.y atau 3.x.y terakhir.

Anda tidak kehilangan apapun di Django dengan menggunakan sebuah terbitan lama, tetapi anda tidak dapat mengambil keuntungan dari perbaikan dan optimalisasi di terbitan Python terbaru. Aplikasi pihak-ketiga untuk digunakan dengan Django, tentu saja, bebas menyetel persyaratan versi mereka sendiri.

Haruskah Saya menggunakan versi stabil atau versi pengembangan?

Umumnya, jika anda sedang menggunakan kode di produksi, anda harus menggunakan terbitan stabil. Proyek Django menerbitkan terbitan stabil penuh setiap sembilan bukan atau lebih, dengan pembaharuan perbaikan kesalahan diantaranya. Terbitan stabil ini mengandung API yang melingkupi jaminan kesesuaian kebelakang; jika anda menulis kode terhadap terbitan stabil, anda tidak harus mempunyai masalah mengingkatkan ketika versi resmi selanjutnya terbit.

Back to Top